Results 1 to 9 of 9
  1. #1
    brittone2 is offline Blue Diamond level (20,000+ posts)
    Join Date
    Nov 1999
    Location
    back to where we started
    Posts
    23,590

    Default LOFT order issue

    So I ordered 3 items the other day from LOFT during the 30% off sale. I was tracking those items over the last few days and was excited they were due to arrive today. One is a swim suit, and I want to get it tried on and ruled in or out. I have some others in mind and I always wait too long and have my size sell out, so I want to start early.

    Anyway, today I receive a package, and it contains 3 items. But not one single item is something I ordered. The correct packing slip is in there, I verify that I ordered the right things, double check my email confirmations, etc. Yep, everything is okay on my end. But yeah, the items in my package have nothing to do with what I ordered.

    I called LOFT, and I'm asked for my info, the SKU #s of the items I received. CS rep tells me they will be "investigating over the next 3-5 days. Based on the results of the investigation, we'll contact you with how to proceed, decide whether we need to reorder, refund, etc.."

    I laughed. I didn't mean to. I apologized to the CS rep and said I was just surprised that it was going to take that long to rectify things, and that I realize it isn't her fault.

    Really LOFT? You can't just like ship the RIGHT items out to me, like ASAP, to make it right? I've been waiting a week, and now what, another 3-5 business days, and *then* you'll ship the right items out to me and tell me what to do with what I have here? Thanks. That's super awesome. Especially because today is Friday and oh, 3-5 Business days will be a while!

    I once received the wrong items from Hanna Andersson. I think they just shipped the correct items right away, but that was years ago.

    Maybe I am asking too much. It just seems ridiculous that it would take that long to "investigate." But thanks, LOFT! I haven't ordered online from you in years but this isn't making me feel really good about the CS.

    edited to add:
    I updated in the Lounge, but will update here.

    I called back and asked for a manager. I was asked why, so I went through what happened in the earlier call, and said that once I had a chance to process it, it really seemed terribly unfair, etc. The CSR did not put a manager on the phone, but told me "there *is* another way we can handle this." So I'm calling UPS, they are picking it up, and they reordered for me. However, they insisted that I'll have a double charge until they receive the incorrect order back, and then they will credit me.

    Thanks for the sanity check. I hung up after the initial conversation and just thought, why do I feel like that was all wrong?? and then thought maybe I was being unreasonable. The whole thing just left a bad taste in my mouth.

    I am going to write corporate now, because the whole thing was just awful. I won't be ordering from ATL. It was a pretty terrible experience.
    Last edited by brittone2; 02-22-2013 at 06:38 PM.
    Mama to DS-2004
    DD-2006
    and a new addition-ds born march 2010

  2. #2
    brittone2 is offline Blue Diamond level (20,000+ posts)
    Join Date
    Nov 1999
    Location
    back to where we started
    Posts
    23,590

    Default

    Today, I received a survey in my inbox. When I complete it and submit, I keep getting an error message saying I "must use SSL to access this service." I don't even know what that means, but I can't even fill out their survey
    Mama to DS-2004
    DD-2006
    and a new addition-ds born march 2010

  3. #3
    citymama is online now Pink Diamond level (15,000+ posts)
    Join Date
    Dec 2005
    Location
    .
    Posts
    18,567

    Default

    Oh.my.goodness. That is INSANE customer service.

    I once had a HORRIBLE experience with Eddie Bauer online. As in, I had a gift cert, entered the code, got the amount taken off, disposed of the code when my items arrived (receipts have no prices). But when I received my cc statement, I had been charged the full amt to my cc. When I called, a rude CS person said she couldn't do anything for me without my gift cert code and actually hung up on me. I went to their website, pulled some quotes from their founder who said the customer was always right, and typed out a long LETTER to them which I mailed and emailed. I received a call back from a manager who apologized, credited me the amount of my gc, and mailed me an additional GC of the same amount. Sometimes you need to put it in writing. You can also contest the cc charge if they don't resolve it.

    Oh, and EB's website is still riddled with bugs. I'll never order there online again!

    for Sandy Hook



  4. #4
    Join Date
    Feb 2006
    Location
    .
    Posts
    547

    Default

    Quote Originally Posted by brittone2 View Post
    Today, I received a survey in my inbox. When I complete it and submit, I keep getting an error message saying I "must use SSL to access this service." I don't even know what that means, but I can't even fill out their survey
    SSL is a secure web site. The address will be prefaced with "https://" instead of "http://". I wonder if the link they sent you is missing the 's'? They should have it set up to redirect to https, but maybe the programmers screwed up. So, check the URL in the address bar. If it doesn't have an 's' after the "http", add it in yourself, then hit enter to go to the new address and see if that allows you to complete and submit it.

  5. #5
    brittone2 is offline Blue Diamond level (20,000+ posts)
    Join Date
    Nov 1999
    Location
    back to where we started
    Posts
    23,590

    Default

    Quote Originally Posted by tg_canada View Post
    SSL is a secure web site. The address will be prefaced with "https://" instead of "http://". I wonder if the link they sent you is missing the 's'? They should have it set up to redirect to https, but maybe the programmers screwed up. So, check the URL in the address bar. If it doesn't have an 's' after the "http", add it in yourself, then hit enter to go to the new address and see if that allows you to complete and submit it.
    Thanks for the info. There's an https as the first part of the link they sent. I just got a 2nd survey (2 phone calls to their 1 888 number, so separate poll for each), and as soon as I submit, I get the same SSL error code for some reason.
    Mama to DS-2004
    DD-2006
    and a new addition-ds born march 2010

  6. #6
    Join Date
    Feb 2006
    Location
    .
    Posts
    547

    Default

    Quote Originally Posted by brittone2 View Post
    Thanks for the info. There's an https as the first part of the link they sent. I just got a 2nd survey (2 phone calls to their 1 888 number, so separate poll for each), and as soon as I submit, I get the same SSL error code for some reason.
    Well that's a sure fire way to never get bad feedback...don't let user's submit the survey! Sounds like some bad programming. Sucks you're not able to provide your feedback.
    Last edited by tg_canada; 03-13-2013 at 11:33 PM.

  7. #7
    Join Date
    Jul 2008
    Posts
    770

    Default

    omg brittone this just happened to me! I just opened my Loft order and the packing slip is correct, but none of the items are what I ordered. Insane that this exact scenario happened to me as well - what is going on with their systems? Thank you for posting this - I'm on hold with customer service and will insist on speaking with a manager as well.

  8. #8
    brittone2 is offline Blue Diamond level (20,000+ posts)
    Join Date
    Nov 1999
    Location
    back to where we started
    Posts
    23,590

    Default

    Quote Originally Posted by alootikki View Post
    omg brittone this just happened to me! I just opened my Loft order and the packing slip is correct, but none of the items are what I ordered. Insane that this exact scenario happened to me as well - what is going on with their systems? Thank you for posting this - I'm on hold with customer service and will insist on speaking with a manager as well.
    Oh no! I hope you get a better resolution with less of a headache! That is so weird.
    Mama to DS-2004
    DD-2006
    and a new addition-ds born march 2010

  9. #9
    Join Date
    Jul 2008
    Posts
    770

    Default

    The CS rep I spoke to was very apologetic and nice. She re-sent the missing items with free 3-day shipping (I think she did have to re-purchase, but I saw a credit already so I wasn't charged twice). I do have to send back the other items, but I frequently drive by the UPS store, so not a big deal. So strange though - I guess this is a recurring issue with their system?!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •